ImmoTool Server startet nicht -> Fehlermeldung

Technische Fragen & Probleme zum OpenEstate-ImmoTool
Forum rules
Bitte beachten Sie die allgemeinen Forenregeln, bevor Sie sich an der Diskussion beteiligen.

ImmoTool Server startet nicht -> Fehlermeldung

Postby Marian S » Mon 28. Aug 2017, 18:00

Hallo,
wir wollen umrüsten auf ein Mehrplatzprojekt und dazu teste ich gerade am Server rum. Ich habe die neueste Version geladen (Beta3).

Auf einem Windows Rechner klappt der Start des Servers gut, sofern ich die start.bat oder start.exe ausführe. Was jedoch nicht geht ist die im Handbuch beschriebene Version über die Kommandozeile:
Code: Select all
java -cp ".\etc;.\lib\hsqldb.jar;.\lib\log4j.jar" org.hsqldb.server.Server --props .\etc\server.properties

http://manual.openestate.org/ImmoTool-1.0/book/ch04s02.html

Es kommt folgende Meldung:
Error: Could not find or load main class org.hsqldb.server.Server

Getestet mit Java 7 und 8.
Auf unserem NAS (Synology mit aktuellster DSM 6) exakt der gleiche Fehler. Ich habe das tar-Archiv auch über die Kommandozeile direkt auf dem NAS entpackt, um zu vermeiden, dass bei der Übertragung irgendwas liegengeblieben ist.
Auch auf dem NAS getestet mit Java 7 und 8.

Da im Handbuch sonst nichts erwähnt ist, wüsste ich auch nicht, was ich falsch mache.
Woran könnte es liegen?

Danke und Gruß,
Marian
Marian S
 

Re: ImmoTool Server startet nicht -> Fehlermeldung

Postby Marian S » Tue 29. Aug 2017, 10:16

Nach weiteren Tests kann ich noch folgendes hinzufügen:

Die oben beschriebenen Probleme sind mit der Version 1.0-beta3.
Mit der 1.0-beta2 klappt der Start des Servers über die Kommandozeile (sowohl am Windows PC als auch NAS). Ist am Paket etwas beschädigt?
Marian S
 

Re: ImmoTool Server startet nicht -> Fehlermeldung

Postby Marian S. » Thu 31. Aug 2017, 10:51

Nach weiteren Tests habe ich mir die Startparameter genauer angeguckt, weil der Server über die Start.sh gestartet ist.
Für den neuen Server muss anscheinend die im ersten Post erwähnte Kommandozeile geändert werden in Bezug auf den Classpath.

Bei folgender Option funktioniert der Aufruf dann nämlich:
Windows
Code: Select all
java -cp ".\etc;.\lib\*" org.hsqldb.server.Server --props .\etc\server.properties


Linux
Code: Select all
java -cp ".\etc:.\lib\*" org.hsqldb.server.Server --props ./etc/server.properties
Marian S.
 

Re: ImmoTool Server startet nicht -> Fehlermeldung

Postby Andreas Rudolph » Mon 4. Sep 2017, 14:05

Hallo Marian,

vielen Dank für den Hinweis. Mit Aktualisierung auf den ImmoTool-Server in Version 1.0-beta3 haben sich auch die Dateinamen im lib-Verzeichnis geändert. Daher funktioniert auch der im alten Handbuch dokumentierte Aufruf nicht mehr. Im neuen Handbuch werden wir dies in jedem Falle berücksichtigen.

Nebenbei: Du musst natürlich nicht zwingend den ImmoTool-Server über den Java-Befehl starten. Alternativ sollten auch die Skripte "Start.bat" / "Start.sh" im bin-Verzeichnis verwendet werden können. Im Prinzip machen diese Skripte das gleiche als würde man die von dir genannten Befehle direkt auf der Konsole ausführen.
Mit freundlichem Gruß / Yours sincerely
Andreas Rudolph
User avatar
Andreas Rudolph
 
Posts: 3739
Joined: Tue 16. Feb 2010, 21:48
Location: Berlin, Germany


Return to Technische Probleme

Who is online

Users browsing this forum: No registered users and 2 guests

cron